This project has moved and is read-only. For the latest updates, please go here.

How to format an encrypted volume

Topics: Technical Issues
Dec 8, 2014 at 6:59 PM
Edited Dec 8, 2014 at 9:45 PM
Can anyone please help me here. I cannot find out how to format a VeraCrypt encrypted volume to NTFS. I created the 900Gb encrypted volume on an external USB disk of 931Gb NTFS (Windows 7)
I choose Fat32 because VeraCrypt cannot create NTFS volumes. No problem I thought, I can format the volume, I read discussion:570017 on this forum.
When I mount the volume however, it is not recognized as a disk in disk management. The 931Gb NTFS disk where the volume resides is recognized and that one is already NTFS, whereas the encrypted volume is Fat32. Apart from that it works fine, no problem there, but I need NTFS.
I have tried several partition managers but only the 931Gb NTFS external USB drive shows, not the mounted volume.
I used TrueCrypt and never had this problem, so I do not know how to remedy this. Any help most welcome.

I reply to my own question. I am from Windows 95 and later and have little DOS knowledge, but I found out that formatting from the commandprompt of with Powershelll (both as admin) works wand convert X: /FS:NTFS, where X is the encrypted volume, but I guess you guys already knew about this :-)
Dec 9, 2014 at 1:38 PM

Glad to see that you were able to solve your issue.

The only thing is that VeraCrypt on Windows supports creating NTFS volumes from the GUI so I'm wondering why you were not able to do so directly. Did you encounter any errors when you selected NTFS as the filesystem type in VeraCrypt? Did you use VeraCrypt on Linux for the creation of the partition?
Dec 9, 2014 at 1:54 PM
When I opted for NTFS from within the user interface of VeraCrypt after an 10 hour job I got the message the volume could not be created because admin privileges were needed. There was no volume created. So then I decided to create the volume as admin, but VeraCrypt told me that volume would only be accessible for user(s) with admin priviliges.
Then I decided to run the job anew and create a Fat32 volume and format it to NTFS later, based on your suggestion in discussion:570017.
That finally worked out fine after I discovered the joys of the command prompt.
As per your question: I use VeraCrypt on Windows 7, from the GUI, to create a volume on a (NTFS) Seagate external USB drive on the same platform.
I have no clue why it did not work, I did not have this issue with TrueImage.
But apart from this all, I am very happy you created a fork to continue and improve TrueCrypt. Thank you very much for this job!
Dec 9, 2014 at 2:17 PM
Edited Dec 9, 2014 at 3:49 PM
Thank you for your explanations.

Actually what happened is that VeraCrypt asked for the administrative privileges using the usual UAC dialog but I guess you were not around when it was displayed because of the long operation time and so it had timed out (Windows defines a 2 minutes timeout for the UAC dialog) which in turns caused the error in VeraCrypt.

Admin privileges are needed in order to use Windows native NTFS API that is used for formatting the encrypted volume. Starting VeraCrypt as admin is a solution if you know that you will not be always in front of your PC screen.
Of course the warning discourages this because of there are cases where this could lead to files that can't be written by normal users but in most cases there will be no issues because the current user is the same as the UAC user.

Anyway, the UAC timeout is an annoying issue but unfortunately there is no documented way to increase the timeout or to distinguish between timeout and cancel operation.
Dec 9, 2014 at 2:23 PM
Thank you very much idrassi, this is a clear and helpful explanation of what happened.
Jan 6, 2015 at 9:19 PM
I just ran into the same situation. I was setting up a 256GB encrypted NTFS volume and wasn't able to wait around for the 2 hours or so that the preparation would take. When I came back I saw that Veracrypt was unable to create the volume because admin privileges were needed. I decided to just run Veracrypt as adminstrator the next time: so far that hasn't caused any problem reading or writing to the encrypted volume where I need to be able to do so.

idrassi: I can think of two possible ways you might be able improve upon this situation. First of all, could you somehow force the UAC dialog come up -before- the long preparation phase, and then retain those administrator rights when you use the native NTFS API later? If that is not possible, could you perhaps display your -own- modal dialog (with no timeout) before triggering the UAC dialog? It could say something like "Veracrypt is about to request administrator privileges. You will have two minutes to acknowledge the request." It seems you know whether or not the UAC dialog is going to appear, because you display the warning about running Veracrypt as administrator in the volume creation wizard.

By the way, thanks (to whoever is responsible) for the program and for providing such an informative and helpful GUI for what is necessarily a complex task. The option descriptions in Veracrypt are really great!
Jan 7, 2015 at 7:54 PM
Thank you spensak for your feedback and your proposals.

The simplest solution I think is to simply ask the user if we should try again to get Admin right instead of aborting with an error. That way, if a UAC timeout occur because the user was not in front of the PC, he can simply resume the process from where it stopped.
Jan 7, 2015 at 10:18 PM
Jan 8, 2015 at 10:40 AM
I like the simple solution you mention Idrassi and look forward to it being implemented in VeraCrypt.